L2002 Gauges

ndenahan

New member

Equipment
L2002
Sep 1, 2018
29
5
0
Gainesville, FL
Hi all new to the forum.
I just picked up a ugly L2002 that runs well.
The gauges all seem dead but the fuel gauge.

are these likely to be replaceable?
does anyone know if some US model shared the same dash?

Thank
 

85Hokie

Moderator
Staff member
Lifetime Member

Equipment
BX-25D ,PTB. Under Armor, '90&'92-B7100HST's, '06 BX1850 FEL
Jul 13, 2013
10,319
2,152
113
Bedford - VA
upload some pics - lets have a look-see of the ol girl:)
 

85Hokie

Moderator
Staff member
Lifetime Member

Equipment
BX-25D ,PTB. Under Armor, '90&'92-B7100HST's, '06 BX1850 FEL
Jul 13, 2013
10,319
2,152
113
Bedford - VA
ugly is in the eye of the beholder.....
fine looking machine. Good pictures too.
I am going out on a limb - that TACH, is it a mechanical tach? Cable running from back to the engine or someplace? IF so - remove that and see if that is fixable.

CHECK all the fuses, and while under the hood, check to see if any wires have chafed via rats/mice or oxidation.
 

ndenahan

New member

Equipment
L2002
Sep 1, 2018
29
5
0
Gainesville, FL
I looked at the tach cable.
The cable is missing the drive end at the top so it looks like I'll need to order one.
The temp gauge I'm not sure about. It seems to have multiple sending units? or maybe one is oil pressure?

I also noticed the battery was installed backwards with a positive ground so I switched that around and now what I assume is the your battery is not charging light is on. looks like a lightning bolt?

the L275 has the same motor as this so I think if I can find the parts manual for that I can track down some parts I'm just not sure about that dash/gauges.

Thanks for your help.
 

D2Cat

Well-known member
Lifetime Member

Equipment
L305DT, B7100HST, TG1860, TG1860D, L4240
Mar 27, 2014
12,972
4,359
113
40 miles south of Kansas City
Kind of odd it runs well with the battery installed backwards! Would normally melt the fusible link going to the starter.
 

ndenahan

New member

Equipment
L2002
Sep 1, 2018
29
5
0
Gainesville, FL
I thought it was odd that it started at all with the battery backwards but I'm pretty sure the cable that bolts right to the frame from the post is the ground and I'm equally sure that this tractor should be negative ground. Now I'm not saying somebody before me hasn't removed a fusible link over the years.

I also checked out the fuse box. It like the rest of this little beast looks a little rough. I'll see about getting pictures in the daylight. One wire wants to fall of. one fuse is blown and one fuse is missing the little metal clip on one side that holds it down. I pretty surprised anything works on this tractor!
 

North Idaho Wolfman

Moderator
Staff member
Lifetime Member

Equipment
L3450DT-GST, Woods FEL, B7100 HSD, FEL, 60" SB, 743 Bobcat with V2203, and more
Jun 9, 2013
28,567
5,035
113
Sandpoint, ID
The reason the charge light is on is it's not charging as they had to have the regulator hooked up backwards for it to work with the polarity reversed.
You probably going to need a new regulator! ;)
 

ndenahan

New member

Equipment
L2002
Sep 1, 2018
29
5
0
Gainesville, FL
I think I found out why it doesn't charge.


I believe this red wire should go to something.


Here is the fuse block


You can see the top fuse is missing the clip on the left hand side and the 3rd fuse down is blown.

Here is the voltage regulator I guess it can hurt to replace it.


That number if you can't make it out is 026000-2121
for anybody that has one of these and needs to know.
https://www.amazon.com/Voltage-Regulator-Mechanical-Kubota-Hitachi/dp/B01GPH8QPM
 

ndenahan

New member

Equipment
L2002
Sep 1, 2018
29
5
0
Gainesville, FL
85Hokie you were right on about the tach. I purchased the cable for the L275 listed as the us version of my 2002. Tossed it in this evening and whamo I have a working Tach!
I start to think I can make this into I nice little tractor.

I'll need to chase down the wire to replace but I think that not to too hard just tedious.

Thanks for your help !
 

85Hokie

Moderator
Staff member
Lifetime Member

Equipment
BX-25D ,PTB. Under Armor, '90&'92-B7100HST's, '06 BX1850 FEL
Jul 13, 2013
10,319
2,152
113
Bedford - VA
85Hokie you were right on about the tach. I purchased the cable for the L275 listed as the us version of my 2002. Tossed it in this evening and whamo I have a working Tach!
I start to think I can make this into I nice little tractor.

I'll need to chase down the wire to replace but I think that not to too hard just tedious.

Thanks for your help !
Check that fuse box.....all those connections look...mmmm....well.... needing some TLC:D:).

The temp gauge should be "fairly" easy to trace down and hopefully fix too. :)