M7040 No power to dash, no start

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
Ok guys, time to do that last thing men do...ask for help.

I have a 2011 M7040. A couple weeks ago the tractor would not start, had no power to dash. I charged up the battery, no help. Next day I walk out thinking I'm going to dig into this thing, starts right up like normal. Finished my chores, turned tractor off, wont start again. Ran a test light to the key switch and I'm showing power but when the key is turned to start the power doesn't transfer to any other wire. Has to be switch right? No. Ordered brand new switch from kubota, installed and the damn thing cranks right up. problem solved? Nope. I started it this morning with no problem, tried to start this evening and back to square one. All fuses look good and basically the damn thing starts whenever it wants. The light comes on with door open so I'm definitely getting power to the cab. I'm not sure where to go from here. Any help is appreciated. Thank you.
 

Roadworthy

Active member
Lifetime Member

Equipment
L2501 HST
Aug 17, 2019
604
33
28
Benton City, WA
Clean both battery terminals inside and out. Make sure the ground side of the battery has a good clean connection to the frame of the tractor. Start with the easy really basic stuff.
 

Tx Jim

Member
Lifetime Member

Equipment
M7040 HDC-1
Apr 30, 2013
885
1
18
Coyote,Flats,Texas
Welcome to OTT
Ditto what Roadworthy stated. Have you cleaned/tightened all four(4) battery cable connections?
 
Last edited:

Dave_eng

Well-known member
Lifetime Member

Equipment
M7040, Nuffield 465
Oct 6, 2012
2,974
70
48
Williamstown Ontario Canada
I have attached the wiring diagram for the start circuit and the troubleshooting chart.

Start with Roadworthy's suggestion.

In the start circuit there is a 5 amp fuse, start relay, neutral safety switch on shuttle shift, pto safety relay, and lastly pto switch.

After cleaning the battery connections, my next step would be to jump the starter to make certain the most basic component is working.

If you do not know how to do the starter jumping safely please ask first.

Dave
 

Attachments

leveraddict

Member

Equipment
2017 BX23S 60 Landpride box blade 54" belly mower 60" County line back blade
Apr 1, 2019
78
2
8
Madison,Pa.
I had a similar experience! The plug going to the starter that snaps together was still snapped together but had some back and forth play! Just enough to disconnect but still snapped together! Thats one sloppy plug on my BX! Lucky I found it just before the dealer was about to pick it up! I still had power to the dash though.
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
Cleaned all battery terminals, checked all ground connections. All fuses look good, I even pulled out ever single one and cleaned all contact points. I had the issue with the PTO switch before but it didn't prevent power to the dash lights. Imagine turning the key as if the battery was completely dead but the battery is fine. The couple of rare times it decided to start it started very strong with no hesitation. It started yesterday but I didn't move the tractor at all, didn't change gears or even sit in the seat. I cranked it, let it run for a bit and shut it off. Later that evening there was no power again but I have the cab light come on.
 

Dave_eng

Well-known member
Lifetime Member

Equipment
M7040, Nuffield 465
Oct 6, 2012
2,974
70
48
Williamstown Ontario Canada
Cleaned all battery terminals, checked all ground connections. All fuses look good, I even pulled out ever single one and cleaned all contact points. I had the issue with the PTO switch before but it didn't prevent power to the dash lights. Imagine turning the key as if the battery was completely dead but the battery is fine. The couple of rare times it decided to start it started very strong with no hesitation. It started yesterday but I didn't move the tractor at all, didn't change gears or even sit in the seat. I cranked it, let it run for a bit and shut it off. Later that evening there was no power again but I have the cab light come on.
A few questions so I can better understand.

When the tractor is unresponsive are you saying the only thing to work is the cab dome light? The upper front and back lights wont work? The headlights wont work? Radio wont work?

Is there power in the cigarette lighten socket?

Dave
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
A few questions so I can better understand.

When the tractor is unresponsive are you saying the only thing to work is the cab dome light? The upper front and back lights wont work? The headlights wont work? Radio wont work?

Is there power in the cigarette lighten socket?

Dave
Power to dome light. No power to cig, radio, A/C, Dash lights, work lights front or rear, wipers, headlights, guages.

This morning I went to start it, started fine, no issues at all. Didn't move it at all or mess with anything at all. Just start, ran for a few, turned it off. Took my daughter to doc. Appt., went to start it and nothing again. When it starts, it starts without issue. When it wont start I get absolutely nothing when I turn the key. It's about as random as it gets.
 

AllDodge

Member

Equipment
M9540 RTV1100
Jan 19, 2019
178
0
16
South Central, ky
Power to dome light. No power to cig, radio, A/C, Dash lights, work lights front or rear, wipers, headlights, guages.

This morning I went to start it, started fine, no issues at all. Didn't move it at all or mess with anything at all. Just start, ran for a few, turned it off. Took my daughter to doc. Appt., went to start it and nothing again. When it starts, it starts without issue. When it wont start I get absolutely nothing when I turn the key. It's about as random as it gets.
Its wire or connection from Starter to Fuse to Key. Something in the chain has some corrosion or bad connection, my guess is corrosion.
 

Dave_eng

Well-known member
Lifetime Member

Equipment
M7040, Nuffield 465
Oct 6, 2012
2,974
70
48
Williamstown Ontario Canada
Power to dome light. No power to cig, radio, A/C, Dash lights, work lights front or rear, wipers, headlights, guages.

This morning I went to start it, started fine, no issues at all. Didn't move it at all or mess with anything at all. Just start, ran for a few, turned it off. Took my daughter to doc. Appt., went to start it and nothing again. When it starts, it starts without issue. When it wont start I get absolutely nothing when I turn the key. It's about as random as it gets.
Do the 4 way flashers work when everything is dead?

They are on the same circuit as the dome light which means power should be always there.

Dave
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
Its wire or connection from Starter to Fuse to Key. Something in the chain has some corrosion or bad connection, my guess is corrosion.
Ok gents, I had some time today to dig into this thing. I checked every fuse, relay and connection. Hot tested everything. Power to new key switch, starter, all fuse boxes have juice. Disconnected all pigtails and cleaned them out. Removed all relays and wire brushed the contact points. Swapped all matching relays to see if there is any change in function. Absolutely no luck at all. Neighbor has a new tractor, swapped batteries (yes, I have neighbors like that. It's awesome). No change at all. Grounds are all good. Traced what I could in the wiring harness for shorts or breaks. I came up with nothing...Pretty mechanically sound. Electrical is not my specialty but I'm not a novice either. Anyone have a new idea of what I'm missing?
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
Do the 4 way flashers work when everything is dead?

They are on the same circuit as the dome light which means power should be always there.

Dave
No, dash is dead. No flashers, gauges, horn doesn't work, no headlights or individual turn signals.
 

lugbolt

Well-known member

Equipment
ZG127S-54
Oct 15, 2015
2,217
37
48
Mid, South, USA
If it's a cab model, pull the floor mat out, you will see a bolted-in tunnel. Remove it. Underneath are the wirings. Disconnect the connectors and clean them and see if that solves your issue. I've seen some of the connectors so corroded that they wouldn't come apart without damage; in that case, cut them off and hard-wire them; unless you have access to new connectors and pins then just replace them.
 

AllDodge

Member

Equipment
M9540 RTV1100
Jan 19, 2019
178
0
16
South Central, ky
Need to be using a voltmeter, test lights just says there is something there.

Can check voltage drop by placing a meter probe on each end of a single wire. Should read next to nothing, finding more shows possible corrosion.

Remove and try to look under the insulation jacket at the wire ends. The jacket can look great and may be badly corroded under
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
If it's a cab model, pull the floor mat out, you will see a bolted-in tunnel. Remove it. Underneath are the wirings. Disconnect the connectors and clean them and see if that solves your issue. I've seen some of the connectors so corroded that they wouldn't come apart without damage; in that case, cut them off and hard-wire them; unless you have access to new connectors and pins then just replace them.

Buddy, you are a life saver. Burned connection. Going to run a jumper on them and let you know how it goes. Hopefully this is it.
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
Ok I have power to dash and she cranks but no start, no headlights, no blinkers, brake lights, horn, etc. Progress has been made. Got late so I'll mess with it tomorrow. Thanks everyone for the help. I'm sure I'll have it back in service tomorrow.
 

Palominofarmer

New member

Equipment
Kubota M7040
Dec 2, 2019
10
0
0
VADO
If it's a cab model, pull the floor mat out, you will see a bolted-in tunnel. Remove it. Underneath are the wirings. Disconnect the connectors and clean them and see if that solves your issue. I've seen some of the connectors so corroded that they wouldn't come apart without damage; in that case, cut them off and hard-wire them; unless you have access to new connectors and pins then just replace them.

Hey man, you were spot in. One of the connectors was burned up under there. Hard wired everything and she starts right up now. However, I have no lights, flashers, radio, or headlights. I do have A/C, wipers, work lights front and rear. Any idea where to go from here?