L4701 warms up then stalls

Gsweet1

New member

Equipment
L4701 with fel and woods bb72.30 bush hog
Sep 23, 2021
1
0
1
Winchester, Kentucky
I have a L4701 about a year old with 28 hours. It just ask for its first regeneration. During the regeneration the tractor stalled and quit. It would start back after a minute or two but would quit in a couple minutes. I took the tractor home at a slow idle. The next day after starting regeneration and it quoting a bunch of times it finished the regeneration process and the light went out. Thinking the stalling was because of the regeneration I started mowing and after about ten minutes it quit and after a couple minutes it will start back run a couple minutes and quit again. It starts fine and runs perfect until it gets warm then starts quitting. It doesn’t get hot the temp gauge goes middle of the white and stays there. It only has 28 hours and is only a year old so I don’t think the fuel filter is clogged and it runs fine until it quits. The air filter was clean as could be. It is down to a quarter tank of fuel so I was thinking of putting some fresh fuel in but if I had water or dirty fuel it wouldn’t start and run perfect until it starts quitting. Thanks for any help or ideas you might have. I know this is a long post I am trying to give you all the info I can. Thanks again
 

fried1765

Well-known member

Equipment
Kubota L48 TLB, Ford 1920 FEL, Ford 8N, SCAG Liberty Z, Gravely Pro.
Nov 14, 2019
2,065
1,441
113
Eastham, Ma
I have a L4701 about a year old with 28 hours. It just ask for its first regeneration. During the regeneration the tractor stalled and quit. It would start back after a minute or two but would quit in a couple minutes. I took the tractor home at a slow idle. The next day after starting regeneration and it quoting a bunch of times it finished the regeneration process and the light went out. Thinking the stalling was because of the regeneration I started mowing and after about ten minutes it quit and after a couple minutes it will start back run a couple minutes and quit again. It starts fine and runs perfect until it gets warm then starts quitting. It doesn’t get hot the temp gauge goes middle of the white and stays there. It only has 28 hours and is only a year old so I don’t think the fuel filter is clogged and it runs fine until it quits. The air filter was clean as could be. It is down to a quarter tank of fuel so I was thinking of putting some fresh fuel in but if I had water or dirty fuel it wouldn’t start and run perfect until it starts quitting. Thanks for any help or ideas you might have. I know this is a long post I am trying to give you all the info I can. Thanks again
New with only 28 hours?
Why troubleshoot on your own?
Must be under warranty.
Call your dealer!
 
  • Like
Reactions: 1 user

lugbolt

Well-known member

Equipment
ZG127S-54
Oct 15, 2015
4,142
1,163
113
Mid, South, USA
may or may not be under warranty...depends. It's a LIMITED warranty, per the warranty statement.

To me, it sounds like fuel starvation BUT without being there with the tractor, it would be hard to pinpoint.
 
  • Like
Reactions: 1 user

GeoHorn

Well-known member
Lifetime Member

Equipment
M4700DT, LA1002FEL, Ferguson5-8B Compactor-Roller, 10KDumpTrailer, RTV-X900
May 18, 2018
4,130
1,797
113
Texas
Try running it with the fuel cap loose. (Tank vent problem?)
 
  • Like
Reactions: 1 user

TGKY

Member

Equipment
L4701DT
May 24, 2018
80
26
18
US
I have the exact same set up as you- 4701 w/ a woods BB72.30. Purchased last Sept with 102 hrs. I do have the DT gear drive version, so that may or may not be a difference. I'm in West KY and see you are in Winchester.

Mine hasn't exhibited any of the symptoms you are describing. I second the call to the dealer absent an obvious fix.

This is my first tractor with an ECM, so a lot of what I used to know from older tractors could be different. You're dealer should be able to help.

Also, I think there is a trouble shooting section in the manual. I'm not near mine right now, but that may be a good place to start as well.

I'll follow here and check my manual tonight.
 
  • Like
Reactions: 1 user

Nicksacco

Active member

Equipment
Kubota L35 TLB
Sep 15, 2021
337
156
43
Bahama, NC
With a year old and only 28 hours, I was wondering if alge, water, rust or something else has plugged up the tank/fuel filter.

Maybe a simple thing to try first is disconnecting the fuel line at the filter and see if you get fuel easily - looking for crud in the fuel. Next might be to examine the filter.

yea, check on the warranty.
 
  • Like
Reactions: 1 user