Lubing PTO cable and linkage

meridien

New member

Equipment
2017 L3301HST, LA525, RCR1260
Aug 11, 2021
5
0
1
SE Indiana
UPDATE: This is on a 2017 Kubota L3301

Wow, that was a bit of a bugger to access. I took off the center cover and the (mostly vertical) panel under the seat. Then I could access the spring return and the PTO control shaft. Good news is that after lubricating the cable and the PTO control shaft, it's working fine.

Before I put the panels back on, I have a question for the forum. What do y'all think about cutting a 2 or 3 inch diameter hole in the panel under the seat to make it easier to lubricate the PTO control shaft? I would put a rubber plug/grommet in the hole that could be easily removed to put some oil on the shaft.

Good idea or not? Any other ideas to make that job a little easier? After seeing how difficult it is to access, I can understand why it might not get the lubrication it needs.
 
Last edited:

old and tired

Well-known member

Equipment
L2800 HST
Dec 8, 2019
892
383
63
Raleigh, NC / Hillsville, Va
Leave it off... replace it only to sell the tractor... This is NOT a good photo but it's the only one I could find. The middle transmission cover and the under the seat cover are off. Does not hamper anything. Allows the area to be blown off with an air gun...
PTO thing.jpg

This is how I run with no covers...
 
Last edited:

lugbolt

Well-known member

Equipment
ZG127S-54
Oct 15, 2015
3,778
873
113
Mid, South, USA
u can lube the shaft/spring assembly without removing the cover.

use the straw on a can of wd40 or your favorite lubricant, stuff it in between the floor hump cover and the rear panel and spray away. That's about all you need to lube anyway. The cable rarely ever needs anything.
 

UpNorthMI

Well-known member
Lifetime Member

Equipment
L3200, L3901, MX5800, SVL75-2, KX040
May 12, 2020
763
486
63
Up North, MI
My L3901 suffers with the pto engagement shaft not moving as freely as it should, I find myself paying special attention to keeping the cable, spring, shaft assembly all lubricated. Maybe there should be a stronger spring on this assembly to disengage the pto. I spend my time under the tractor to ensure the lube hits the right place!

Anyone else suffer with this problem or have and better recommendations than just lubing the engagement shaft and spring?
 

lugbolt

Well-known member

Equipment
ZG127S-54
Oct 15, 2015
3,778
873
113
Mid, South, USA
Unfortunately due to the design, there isn't much that can be done aside from completely reengineering it. It became part of normal servicing when I was doing dealer work. Oftentimes not even normal servicing, if I saw one that was sticking-even if I was fixing a tire, I'd spray it down and make sure it was freed up.

Kubota is fully aware of the issue. Or more specifically, the folks at DFW training center are fully aware.
 

retired farmer

Member

Equipment
tractor, loader, cutter, blade
May 25, 2020
89
49
18
sheridan
Had this cable problem from the get go with my 3301, even replaced cable by the dealer soon after delivery. I am thinking of a way to make a lever system or similar to do away with the cable. Anyone with ideas or has done this would pass on the info. Would be appriecated by me and others I presume.
thanks.
 

old and tired

Well-known member

Equipment
L2800 HST
Dec 8, 2019
892
383
63
Raleigh, NC / Hillsville, Va
...I am thinking of a way to make a lever system or similar to do away with the cable. Anyone with ideas or has done this would pass on the info...
I assume you have HST... the DT model and F (2 wheel drive) have the lever to engage the PTO. Only problem is that it's pretty close the the reverse petal of the HST, thus we have a cable...

I could access mine pretty easily to put a shifter on but my cable works just fine...
 

Attachments

retired farmer

Member

Equipment
tractor, loader, cutter, blade
May 25, 2020
89
49
18
sheridan
I assume you have HST... the DT model and F (2 wheel drive) have the lever to engage the PTO. Only problem is that it's pretty close the the reverse petal of the HST, thus we have a cable...

I could access mine pretty easily to put a shifter on but my cable works just fine...
Yes I do have the hst Old and Tired. Thanks for the diagram.
Thanks for the reply.
 

MotorCityBear

New member

Equipment
L3901
Aug 3, 2019
22
0
1
Blairsville, GA
My L3901 HST also experiences the PTO not disengaging. The dealer told me to crawl under the tractor and spray Kubota cable lube onto the PTO cable (into the rubber covering) when this happens. REALLY Kubota? How about fixing the problem.