B7100 3ph spool valve binding

torch

Well-known member

Equipment
B7100HSD, B2789, B2550, B4672, RC54-71B, 48" cultivator, homemade FEL and Cab
Jun 10, 2016
2,138
393
83
Muskoka, Ont.
I just got back in from blowing off the ice rink. The 3ph spool valve has suddenly started binding occasionally at random times, usually in the neutral position. Sometimes when trying to lift the blower, other times when trying to lower it. It might be normal 10 or 20 times in a row, then suddenly stick for no apparent reason.

Normally, the lever is a very light, smooth transition. But when it sticks, it really sticks. I checked to see if the stop rod was jamming, but that seems loose in the stops even when the control is stuck. This feels like something is occasionally binding internally.

Any ideas?
 

Lil Foot

Well-known member
Lifetime Member

Equipment
1979 B7100DT Gear, Nissan Hanix N150-2 Excavator
May 19, 2011
6,168
993
113
Peoria, AZ
Sounds like ice. Can you hit it with a heat gun when it sticks?
 

torch

Well-known member

Equipment
B7100HSD, B2789, B2550, B4672, RC54-71B, 48" cultivator, homemade FEL and Cab
Jun 10, 2016
2,138
393
83
Muskoka, Ont.
Sounds like ice. Can you hit it with a heat gun when it sticks?
No sign of ice externally and the valve is inside my cab. Temperature has warmed up to above freezing and I have been working the fluid for a couple of hours, so I doubt anything is freezing internally. Fluid looks good -- completely clear, no signs of dirt or contamination. Using Amsoil synthetic HST fluid.
 

Lil Foot

Well-known member
Lifetime Member

Equipment
1979 B7100DT Gear, Nissan Hanix N150-2 Excavator
May 19, 2011
6,168
993
113
Peoria, AZ
Then it must be a loose piece of crud (piece of rust, o-ring?) that is inside floating around where it can jam the spool. Sounds like a dis-assembly & clean may be in your future.
 

SidecarFlip

Banned

Equipment
M9000HDCC3, M9000HD, Kubota GS850 Sidekick
Oct 28, 2018
7,198
528
83
USA
Failed sealing ring cocking in between the bore and spool?
 

torch

Well-known member

Equipment
B7100HSD, B2789, B2550, B4672, RC54-71B, 48" cultivator, homemade FEL and Cab
Jun 10, 2016
2,138
393
83
Muskoka, Ont.
Failed sealing ring cocking in between the bore and spool?
That's what I was starting to think. However, looking at the parts diagram, I don't see any o-rings or seals on the spool.

There's a spring-loaded ball detent mechanism. Looks like that all rides in an oil bath.

<sigh> I think Lil foot is probably right -- there's a disassembly in my future. I wish these things wouldn't happen in winter...
 

SidecarFlip

Banned

Equipment
M9000HDCC3, M9000HD, Kubota GS850 Sidekick
Oct 28, 2018
7,198
528
83
USA
When I bought the M9 years ago, I had an issue with it developing oil pressure. It wasn't building pressure fast enough to satisfy the oil shut down switch and the motor would shut off. Turned out it was a spool valve in the front of the engine that had a burr on it. dealer replace the valve and the entire front cover under warranty.

I know, what does that have to do with your issue... You may have a burr on the spool that is hanging it up, possibly. I was going to mention that in previous post but forgot. Could have a piece of flaked off hose in there as well. I've had that issue in the past too.
 

Lil Foot

Well-known member
Lifetime Member

Equipment
1979 B7100DT Gear, Nissan Hanix N150-2 Excavator
May 19, 2011
6,168
993
113
Peoria, AZ
There's a spring-loaded ball detent mechanism. Looks like that all rides in an oil bath.
I have a B219 FEL with a Cessna valve on mine. When I got it, it would occasionally stick in the float position. It kept getting worse until it locked. Dis-assembly showed that whole detent mechanism has rusted away to junk. Parts were no longer available , and I haven't had time to make new parts, so I just left it out, and hold it in float by hand. The mechanism on mine is not oil bath, so a little water was all it took to destroy it.
Pic shows where the detent setup is located on mine.
 

Attachments