B1600 no charging light

armstrongrv

New member

Equipment
B1600 rotovator and loader
Aug 25, 2020
9
0
1
Scotland
Asked to move this from the main forum as it is a Gray.
I have a B1600 with a D950 engine. when the switch is in the ignition on position the charge light no longer comes on with the engine not running. all other functions work. The oil light comes on and go's off when the engine starts. The glow plugs work ok and the engine starts and runs. Now to the crooks of the problem. from the wiring diagram there is a voltage regulator and a thing called a charger unit. If I put 12 v across the charging light it works so that rules that out. What is the charger unit and what is it doing it looks like the yellow wire is the trigger and as the revs go up I think the voltage came down and if I remember with the switch on I think there is about 10 volts. the parts book that I have calls it a BOX PN 67111 5525-1 and then you have the regulator 155316460-2. Is the Box just a relay that switches off when the voltage drops on the yellow wire. Any recommendations appreciated.
Capture.PNG
 

armstrongrv

New member

Equipment
B1600 rotovator and loader
Aug 25, 2020
9
0
1
Scotland
All fixed after buying a new charger unit and second hand voltage regulator. It turned out to be the W/R wire from voltage regulator to main switch B had a bed connection on the main switch. I could not see it had snapped as the plastic shroud had hidden it. when I had dis connected the wire from the voltage regulator it must have made the connection however when connected back up it must have broke the circuit.