Recent content by CBH

  1. C

    Leaking part....

    Fantastic! Thank you!
  2. C

    Leaking part....

    What is the name of this part? It's leaking and I need to find a gasket! Its on a 1994 D640 engine
  3. C

    Bad Dynamo?

    Here is what I have today. Belt is tight, grounds are cleaned and reconnected. Battery cables removed, cleaned and connected 1) Battery volts before cold start up.... 13.2 V 2) I started it and let it run wide open for 5 minutes....Volts at battery were then 14.83 3) After 15 minutes of wide...
  4. C

    Bad Dynamo?

    I'll do some more investigating tomorrow. Thank you guys for all of the replies!
  5. C

    Bad Dynamo?

    Well, I'm getting those ACV readings at wide open throttle and at idle. I was told it should be 20 to 24. The DC volts at the battery (while running 3/4 throttle) is about 13.2 at start up and then climbs slowly to 15 or more. When I'm mowing...the battery light will flicker, and eventually...
  6. C

    Bad Dynamo?

    With my volt meter set on AC Volts, and touching the 2 wires from the dynamo, I am getting a readout of 16.6 at wide open throttle, and 11.2 at idle. Am I correct in thinking that I need a new dynamo?
  7. C

    Fuel shut off linkage

    Thanks for the reply, D2Cat! It will be repaired later today!
  8. C

    Fuel shut off linkage

    Another pic. Looks to me like it's about ready to let go!
  9. C

    Fuel shut off linkage

    I picked up a little tractor with a D640 in it, and I have found this. I am assuming these parts are severely worn, and NOT suppose to look like this. Correct? I am planning on repairing on replacing the parts.